The Platform is experiencing a heavier load
Incident Report for Seven Bridges Platform
Resolved
This incident has been resolved.
Posted Mar 06, 2020 - 16:05 UTC
Investigating
We are currently investigating this issue.
Posted Mar 06, 2020 - 15:58 UTC
This incident affected: Files.